Caucho Forums  

This forum is permanently closed because of spam. For free community support, please visit Google Groups:


Go Back   Caucho Forums > Resin

Reply
 
Thread Tools Display Modes
  #1  
Old 02-27-2012, 09:56 AM
Wf-Paul Wf-Paul is offline
Junior Member
 
Join Date: Feb 2012
Posts: 2
Default Resin suddenly takes a very long time to start up

We have been using resin 3.17a (yes I know it's an old version) to host our webapp for around 4-5 years now, and never had a problem.

We have resin installed with java 1.6.0_25 on RedHat Enterprise Linux.

Just last week when I restarted resin it hung for a long time on the line "loading .tld files from global classpath". It took more than 7 minutes to advance, then started up as normal.

Previously it only took a few seconds to get past the "loading .tld files...", so I can't understand why it now takes so long. I have the same webapp deployed on resin on this and 4 other machines and none of them have this problem.
I have also tried downloading newer versions of resin and the problem still remained.

There are no error messages shown, even when I set the log level to "finer", so at the moment I have no clues as to why this has occurred.

Any help or suggestions would be appreciated.

Thanks!
Reply With Quote
  #2  
Old 02-28-2012, 12:34 AM
alex alex is offline
Administrator
 
Join Date: Aug 2009
Posts: 218
Default

Hi Wf-Paul,

Can you produce a thread-dump when resin's hanging? Possibly Resin is requesting some file over the network but eventually times out.

You can do so with kill -3 <pid> where <pid> is a process id for resin.
You can get pid using java's jps utility, or with ps -ef | grep java command.

Another option is to use jstack <pid>

You can post the snapshot with your reply

Thanks,
Alex
Reply With Quote
  #3  
Old 02-29-2012, 11:53 PM
Wf-Paul Wf-Paul is offline
Junior Member
 
Join Date: Feb 2012
Posts: 2
Smile Fixed!!

Ok this is now fixed.

Thanks for the tips Alex, I had run strace on the process, but didn't think to try kill -3 which actually gave me better debugging info.

Turns out there was a symbolic link pointing to it's parent folder on our document path, and this was causing resin to search for a long time while looking for .tld files.
Reply With Quote
  #4  
Old 03-01-2012, 03:57 PM
YALDesign YALDesign is offline
Junior Member
 
Join Date: Feb 2012
Posts: 1
Default YAL Design

i want 1 also
Reply With Quote
Reply

Tags
resin, startup, tld

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.