PDA

View Full Version : REPOST: Resin Logging problem


systemsforge
03-22-2010, 03:35 PM
Hi Guys

Sorry for the repost but all was getting was spam comments when i posted this the first time

Sorry if this is a newb question but this is causing a real issue on my server and i cant find an answer anywhere for it

I am trying to turn off logging in resin as it is creating a huge log file which as it gets bigger keeps slowing the server down as it trys to write to it

The file is jvm-default.log,which is located in resin\log folder

I am using resin3.1 on a windows server with railo running as the web server

Here is what i changed in the resin.conf to turn the logging off as per this link
http://www.caucho.com/resin-3.1/doc/config-log.xtp

Here is the code i had before and the code i changed it to with no affect. Any help is really appreciated

it was this
<!--
- Logging configuration for the JDK logging API.
-->
<log name="" level="info" path="stdout:"
timestamp="[%H:%M:%S.%s] {%{thread}} "/>

<!--
- 'info' for production
- 'fine' or 'finer' for development and troubleshooting
-->
<logger name="com.caucho" level="info"/>

<logger name="com.caucho.java" level="config"/>
<logger name="com.caucho.loader" level="config"/>

I changed it to this

<!--
- Logging configuration for the JDK logging API.
-->
<log name="" level="off" path="stdout:"
timestamp="[%H:%M:%S.%s] {%{thread}} "/>

<!--
- 'info' for production
- 'fine' or 'finer' for development and troubleshooting
-->
<logger name="com.caucho" level="off"/>

<logger name="com.caucho.java" level="off"/>
<logger name="com.caucho.loader" level="off"/>

emil
03-24-2010, 07:44 PM
What's filling up the log? Resin shouldn't be adding anything that's not important at the INFO level.

If you want to disable logging output entirely, you can just delete the <log> tag. This is not recommended, but it will certainly eliminate the log filling up. :)

Emil