PDA

View Full Version : IP.Board 3 Requirements Checker


derickso
02-25-2010, 06:46 AM
Hi sorry for the double post, I just ran the requirements checker for IP.Board 3 and received the following:

IP.Board 3.0 Requirements Checker

Checking minimum version (5.2.1)...FAIL
You must be running PHP v5.2.1 or greater to use IP.Board 3.0. You are currently running version 5.2.0. Please ask your host to move you to a server running PHP v5.2.1 or greater.

Checking for SPL...Pass

Checking for DOM XML Handling...FAIL
The DOM XML Handling extension is required for IP.Board 3.0. Please ask your host to install the libxml2 library.

Checking for GD library...Pass

Checking for GD2...Pass

Checking for mysql support...Pass

Checking for JSON...Pass

Please also remember that MySQL 4.1 or higher (MySQL 5.0 or higher preferred) is required for IP.Board 3.0. Ask your server administrator to check the version of MySQL on your server if you are unsure.

Any plans to export a PHP 5.2.1 interface and support libxml2?

Thanks-

emil
02-25-2010, 06:59 PM
I've posted these as bugs here:

http://bugs.caucho.com/view.php?id=3916
http://bugs.caucho.com/view.php?id=3917

The 5.2.1 reporting issue should be easy, but we'll need to check to make sure that's a reasonable thing to do at the moment. The libxml2 I expect would take a bit longer.

Emil