PDA

View Full Version : Eclipse Helios, Plugin 4.0.16 and Hot Deploy


kevin.s
04-06-2011, 04:54 PM
Since I'm new, my last post hasn't shown up yet, but suffice it to say I just got the update for the plugin. So I now have 4.0.16 installed.

My new problem is that when I go to set up a server based on the directions here (http://blog.caucho.com/?p=139), I don't have an option for a Hot Deploy target. The only one I have listed is "Resin 4.0". Am I missing a configuration somewhere?

Thanks in advance for the help.

kevin.s

alex
04-06-2011, 09:02 PM
Hi kevin.s,

We've reworked the plugin to deploy to a webapps directory as an archive, or an exploded webapp directory.

Hot deploy became a remote deploy option which can also be used with a local server.

For local deployments deploying to directory is a better option.

kevin.s
04-06-2011, 10:02 PM
Thanks for the reply, Alex. In that case, I must be doing something else wrong. Whenever I try to run my app on the local server, I get this error:

/usr/local/resin/conf/resin.xml (No such file or directory)
/usr/local/resin/conf/resin.xml (No such file or directory)


Any ideas?

I'm on a Mac and my resin.xml file is actually in /etc/resin, while my resin_home is in /usr/local/resin.

Thanks for your help.

alex
04-07-2011, 03:20 AM
This is something I missed. The plugin uses resin.xml, app-default.xml and health.xml that come in conf directory with the download...

You can either use the 'Download" option to create a new Resin runtime. Or, copy /etc/resin/*.xml to /usr/local/resin/conf/ and re-define the server.

Alternatively, when you install the server, just go with --prefix=/path where path points to your resin distro. This will keep everything in one directory - makes it much easier to manage when things need to be deleted.

kevin.s
04-08-2011, 07:21 PM
Hmmm...

I don't seem to have health.xml, but I created symbolic links in /usr/local/resin/conf/ to the others and it seems to be working now, except I get a "Can't bind to /127.0.0.1:6800" message in the console. Any ideas on that?

Thanks for your help!

kevin.s
04-08-2011, 07:43 PM
Okay...I think I've discovered the cause, but also have another problem.

If my Resin server is running when I run my Eclipse app, I get the error I mentioned in my last post, presumably because there's already a server running and using port 6800.

So I tried to stop the running server before I run my app from Eclipse, but I get a slew of new errors that start with "/var/www/resin-data/default/distcache/mnode.db (Permission denied)", followed by a bunch of other errors that reference mnode.db and the server fails to start.

Suggestions?

kevin.s
04-08-2011, 09:37 PM
Found a work-around...just chmod'ed my web root directory. Not ideal, I know, but it got me up and running and it's only my local dev environment. :o