PDA

View Full Version : Resin as an NT service broken following Windows Update


hcday
01-26-2011, 04:15 PM
I'm supporting a client who has been using Resin 3.1.8 (registered as an NT service) for a few years now. Following a routine restart of the server on 13 January after applying Windows updates, Resin no longer works. Specifically:


No error is reported in the Services window. (Resin appears to have started).
No error is reported in the Windows event log.
Resin does not create a jvm.log file (I had deleted the old one).
In Task Manager's Processes, httpd is running but java and javaw are not.
caucho-status reports the Resin service as "down".


However, if I open a command prompt, go to the Resin home directory and run httpd from there it runs normally.

Technical details:

Windows Server 2008
Windows update applied: http://support.microsoft.com/kb/2419640
Version of Resin: 3.1.8
Flags applied: -service -env -classpath
AV: McAfee Virus Scan Enterprise 8.7.0i. We've tried disabling this before restarting Resin but it didn't help.


Any ideas as to what could have broken the installation as a service?

Thanks in advance,

Henry

reza
01-26-2011, 11:43 PM
Henry,

It's hard to tell what is going on off-hand, but it sounds like the Resin windows service is no longer being called? Is it still registered and set to start automatically?

When you start manually, are the logs being generated?

Thanks,
Reza

hcday
01-28-2011, 11:08 AM
Hi Reza,

Thanks for getting back to me. The Resin service is still registered and set to start automatically, but once the problem started occurring we've tried stopping and starting this service manually - which gives no errors but starts up "too fast" and hasn't actually done anything. No log file is created.

When starting Resin from the command prompt the output goes into the cmd window rather than a log file. This shows all the output that we'd normally expect.

Regards,
Henry

reza
01-28-2011, 02:21 PM
Henry,

Please turn up all the log levels to at least fine (preferably finest): http://caucho.com/resin-3.1/doc/config-log.xtp, make sure that the service is set to automatic, restart the machine and send me the log output. If the service is actually invoking Resin there should be some log output.

If there isn't any log output, the likely issue is that the service is somehow broken and needs to be reinstalled.

Thanks,
Reza

jiucai
04-02-2011, 10:21 AM
Maybe you can uninstall service and re-install service
using setup.exe in resin install dir.