PDA

View Full Version : Resin 3.1.10, Apache 2.2 and PHP 5 on same machine?


Colojo
12-02-2010, 07:42 PM
I tried to search the forums (titles and messages) for "PHP" but kept getting no results. So forgive me if this post is a duplicate.

I have a server with Apache 2.2, Resin 3.1.10 and PHP 5 installed. I need PHP 5 for some Joomla and Wordpress sites on the machine, and Resin for a Java/JSP site on the machine. Apache and PHP were working fine before I installed Resin, but after installing Resin, requests to the Joomla and Wordpress sites are resulting in a 404 error being returned from Resin (index.php not found). How can I prevent PHP requests from going to Resin?

Thanks - Joe

ferg
12-03-2010, 08:11 PM
If you're not using Quercus, you can remove the <servlet-mapping url-pattern="*.php"> from the conf/app-default.xml.

Since mod_caucho selects between Apache and Resin based on the servlet-mappings, you'll need to delete those entries.

The /caucho-status will show the current mappings for mod_caucho.