PDA

View Full Version : Resin in Ubuntu 10.04


afanen01
10-08-2010, 07:52 AM
Hi
I have just installed resin via the deb package and started it.

It is only accessible on port 6600, and gives me a 404 error for every url i visit.

what have i done wrong and how can i fix it?

thanks.

mrucker
10-20-2010, 02:30 PM
I've just installed ubuntu 10.04 server, along with the LAMP option.

Next, I installed Webmin (v1.3...).

Er.. next installed the Open-JDK. Now running "OpenJDK Client VM".. which I <i>presume/hope</i> is a satisfactory jdk.. ?

Lastly, I installed Resin 4.0.12 from scratch ...

Per page 12 of the install and admin manual:

"./configure --prefix=/usr/local/resin \
--with-resin-root=/var/www \
--with-resin-log=/var/log/resin \
--with-resin-conf=/etc/resin"

followed by make and make install.

I had to change the default port in resin.xml from 8080 to 8088 as Tomcat was listening on 8080. I didn't think that would shock things much, but when I go to the port, it has "/ not found on this server" - 404 not found.

I've looked in the /var/www folder - there's the default index.html for that folder, but nothing else. Root owns it as well as the root group.

Any thoughts as to what might be going on? I'm attempting to use this for another product and Resin came highly recommended (vs running this on IIS or Apache...).

Gracci!

Mike Rucker,
Chesapeake College

mrucker
10-20-2010, 03:15 PM
Okees.. after playing around, I seem to have it working.

Here's the difference I think:

#1, gotta love vmware. I went back to post-fresh OS install. No java changes, etc. LAMP is installed. GCC isn't. I neglected to mention apt-get install GCC above.

#2. After monkeying around trying to find JDK again, I found this, which works splendidly (er.. just don't install eclipse...).

http://ubuntuforums.org/showthread.php?t=332674

I followed the same configuration as above (although, I did put the root at /var/resin vs /var/www - other things on the system use that - ).

So the between changing the JDK and changing the root location, I seem to have fixed it, best I can guess.

mrucker
10-20-2010, 03:32 PM
Ok - new one. I can see my new root - but trying to access the admin panel simply returns a 403 Forbidden. >< Root owns the folders/files as well as all of the processes. Any ideas?


Newb problem solved.. edit resin.xml, find that website and allow external login. I'm running this on Ubuntu SERVER - no gui, so having to do my work from a browser on another box. ^_^ By the way, this is on page 16 of the PDF manual...