PDA

View Full Version : Backward compatibility mod_caucho 4.0.10


tomk
09-22-2010, 07:04 AM
Hi All

As far as i see from my tests it's not possible. But i would like to be sure (in case i make something wrong during my tests).

I've compiled mod_caucho from Resin 4.0.10 Sources. For certain reasons i would like to to make a connection from a Apache 2 Webserver / mod_caucho 4.0.10 to a Resin Backend Server 2.0.4. The Backend Server works since years in a productiv environment without problems.

A communication between mod_caucho 4.0.10 seems not possible with Resin Backend Server 2.0.4 according to my tests. Is this correct? Can anyone tell me something about the backward compatibility from the actual mod_caucho with earlier versions?

Thanks for advices.

emil
09-23-2010, 08:52 PM
Hi,

Yes, that's correct -- the version of mod_caucho and Resin must match for them to communicate properly. The protocol between the two changes from time to time, so you'll need to match versions.

Emil