PDA

View Full Version : Starting Resin - /etc/init.d/resin??


CalmDownMonkey
08-29-2010, 02:12 PM
Hi,

I've installed Resin for the first time, according to the instructions here:
http://www.caucho.com/resin/admin/starting-resin-install.xtp

It says in the instructions:
When you installed using the .deb package or when you ran "make install" earlier, the installer created a file named /etc/init.d/resin which contains a standard Unix init.d startup file. This file will start Resin when invoked as:

/etc/init.d/resin start


However, there isn't a file called "resin" inside init.d, so this command doesn't work. I did do all the steps mentioned above, including the ./configure, make, make install. Being new to Linux I'm not entirely sure what went wrong and instructions can still seem a bit cryptic so I'm not even sure where to start looking. I'm running Ubuntu 10, if this matters.

I tried "sudo java -jar /usr/local/resin/lib/resin.jar start" which apparently worked, but whether it worked properly or not is another question because I can't get anything through the browser to verify it's all good.

Any advice?

Thanks

emil
08-30-2010, 08:36 PM
Hi,

Just to check... Did you run "make install" as root? That is did you run "sudo make install"? That should create /etc/init.d/resin. As a non-privileged user, you wouldn't be able to make that file. Also, if you're using another distribution (e.g. CentOS or Fedora), you'll either need to make a "www-data" user and group or edit /etc/resin/resin.xml to change the user that Resin will run as. Our default resin.xml just uses www-data because that's what Debian/Ubuntu use, but you may want a "resin" user or something else.

Emil

floatingworld
09-02-2010, 03:50 PM
I'm running Ubuntu 10, if this matters.
You can use Caucho's Debian package if you add their repository to the apt sources list, by the way.