PDA

View Full Version : cannot delete resin.exe


asksuperuser
06-29-2010, 10:08 PM
I tried to delete resin to reinstall from scratch but it refuses to delete it says "opened in resin". In tasks list I can't see it.

So how to really stop it ? I tried to shutdown it didn't work either.

emil
07-01-2010, 12:03 AM
Hi,

Which version of Resin do you have? If you have Resin 4.0.7 and used setup.exe to install the Resin service, rerun it and remove the service. If you have an older version of Resin and didn't use the setup.exe installer, run resin.exe -remove to remove the service.

After that, restart and Resin shouldn't be run at startup, so you can delete it.

If you're unable to remove the service for some reason, you can at least stop the service from Control Panel -> Administrative Tools -> Services, then delete Resin. The problem with this approach is that you'll have trouble removing the service later (Windows, AFAIK, doesn't expose a user visible way of removing services).

BTW, you should be able to see Resin from the Task Manager if you look at the tasks for all users. There should be two javaw.exe tasks running. The one with the smaller memory footprint is the Watchdog process. If you kill that one, the other one (the Resin process), will die shortly there after.

Best,
Emil

ferg
07-01-2010, 12:04 AM
If you installed Resin as a service, you may need to uninstall it. Also, you'll need to stop any Resin version.

To stop the resin instance, use resin shutdown, because "stop" leaves the watchdog running.